Ideas

This board is only for raising and voting on feature requests (Ideas / Suggestions).
Please raise any Bugs via "Get Help" button on your calendar admin dashboard.

CSS does not work - ai1ec_parsed_css > 404 error (Not Found)

Users: Sometimes (but not always) the calendar won't load correctly, neither on the calendar page nor with shortcodes on other pages. For example, instead of showing the subscribe button with the pop-up menu, it will show a bullet list. It happens every hour. The only thing that works as a temporary fix is resaving the calendar theme options.

Example: http://peclibrary.org/events-calendar/

  • Benjamin
  • Jul 27 2016
  • Shipped to WP & Hosted
  • Attach files
  • David Herrmann commented
    July 27, 2016 16:53

    I downgraded to 2.5.5 to see if it would fix the issue.  The CSS is now stable in desktop browsers, but still displays this problem on iOS, which I don't understand.  Saving theme options fixes the issue temporarily.  Thanks,

  • Jason Noyes commented
    July 27, 2016 16:59

    It should say always, not sometimes. My calendar will not load correctly, ever.

  • Pablo Morano commented
    July 29, 2016 15:36

    I had the same issue and it was solved for a while by deactivating WP Super Cache. 

  • Calvin Yeh commented
    August 02, 2016 23:52

    Hi all.

     

    I'm attaching in this thread a beta version with an attempt to fix this CSS issue. Could you please download and test it?

     

    Thanks!

  • Admin
    Robert Whiteside commented
    August 09, 2016 16:25

    Hey guys, is anybody still having this issue? did the custom plugin with the fix helped?

  • A Nash commented
    August 16, 2016 15:05

    The beta version did not solve the problem for us at peclibrary.org

  • A Nash commented
    August 16, 2016 15:09

    Also tried updating to 2.5.10. Problems persisting. 

  • Greg Falken commented
    August 18, 2016 16:57

    Does 2.5.10 incorporate the fix in the beta? If so, our problem is persisting too. Going to try reverting to 2.5.5.

  • Greg Falken commented
    August 18, 2016 17:04

    FYI, on reverting to 2.5.5 the calendar again lost its CSS. Resaving the theme options brought it back.  On other sites, ai1ec also looses its CSS on updates. On this one the problem occurs between updates. http://www.michaelschererdmd.com/speaking/speaking-calendar/

  • Admin
    Robert Whiteside commented
    August 18, 2016 21:27

    Hey Greg, no, 2.5.10 doesn't contain the fix. The fix was only in that beta pack we provided on this thread, but looks like it didn't work...

    We'll keep looking for the cause.

    Thanks,

    Aristotel

  • Greg Falken commented
    August 20, 2016 14:55

    A few more data points:

    • In 2.5.10 both Gamma and Plana themes lose their CSS connection periodically
    • In 2.5.5 Plana loses its connection
    • In 2.5.5 Gamma does not lose its connection (I've been checking it over the last 24 hours)
  • Bridgette Kossor commented
    November 04, 2016 02:05

    Did you fix this issue? I am now having it on a site I manage - only on Safari. The plugin on the home page is only showing text. Thank you.

  • Bridgette Kossor commented
    November 04, 2016 02:13

    Has there been a fix for this as of yet? I am now having an issue with the plugin displaying properly on a homepage I manage. It seems to be an issue in Safari and on mobile.

  • Moira Ashleigh commented
    December 27, 2016 21:04

    I have been having the same issue - will there be a fix? Is there a way to find a commonality in all these users that we can narrow down any potential conflict. Is anyone looking at this?

  • Benjamin commented
    January 06, 2017 20:18

    Hey guys,

    Do you use a cache plugin and what PHP version are you using?