Ideas

This board is only for raising and voting on feature requests (Ideas / Suggestions).
Please raise any Bugs via "Get Help" button on your calendar admin dashboard.

Calendar isn't displaying correctly

Why is my calendar button's not displaying correctly? Hear is a link to the site.

 

https://captjackphotography.com/calendar/

  • Dylan Anderton
  • Mar 15 2017
  • Needs More Votes
  • Attach files
  • Sunny Lal commented
    March 15, 2017 18:13

    Hello Dylan,

    It looks like a CSS issue. Can you try changing your Wordpress theme to see if it affects the button sizes?

     

    For faster assistance, please log into your Timely account and open a ticket by clicking on the Get Help link, or click here: https://dashboard.time.ly/account/get-help

    Regards,
    Sunny
    Technical Support & Client Success

  • Bill Kupiec commented
    March 18, 2017 19:46

    I'm having a similar problem where the button for the previous month is not displaying correctly: http://www.kupcakesco.com/cupcake-calendar/

  • Erich Würgler commented
    March 19, 2017 18:00

    After upgrading to 2.5.17 the button for the previous month is not displaying at all in most cases. Works correctly after restore to 2.5.16 version.

  • Randy Mitson (Algonquin Outfitters) commented
    March 21, 2017 15:35

    I'm having a similar problem with the button for the previous month not displaying what month that is or even indicating it's a button, still works just no text showing.

    http://algonquinoutfitters.com/calendar/

    See attached screen capture

  • simon brigant commented
    March 22, 2017 00:47

    had the same problem and found a fix :)

    in wp-content/plugins/all-in-one-event-calendar/app/view/calendar/view/month.php : line 176

    you should have the following :

    'text' => '<i class="ai1ec-fa ai1ec-fa-angle-left"></i> ' . array_key_exists( $m, $months ) ? $months[$m] : $m,

    Just ad parenthesis so it look like this :

    'text' => '<i class="ai1ec-fa ai1ec-fa-angle-left"></i> ' . (array_key_exists( $m, $months ) ? $months[$m] : $m),

     

    This is the reason :

    <php
    $var = 3;
    echo "Result: " . $var + 3;
    ?>

    The above will print out "3" instead of "Result: 6", since first the string "Result3" is created and this is then added to 3 yielding 3, non-empty non-numeric strings being converted to 0.
  • Bill Kupiec commented
    March 22, 2017 20:27

    Brilliant, thank you simon brigant! That fixed the problem for me!

  • Randy Mitson (Algonquin Outfitters) commented
    March 27, 2017 18:35

    This was also fixed in the latest release.

  • James Blais commented
    April 21, 2017 13:27

    My site is broken after 2.5.19. I turned off caching plugin, caching on cpanel, cleared browser cache. Nothing seems to fix this plugin.

  • James Blais commented
    April 21, 2017 13:28

    Mine is broken after 2.5.19 upgrade. Turned off cache plugin, caching in cpanel, and cleared browser cache. Nothing worked. http://www.pathfindersmc.org/

  • Gravatar
  • Gravatar
  • Gravatar
  • Gravatar